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Smart & Sassy
Keyboard Shortcuts

A keyboard shortcut is an alternative way to execute a command using a key or a
combination of keys instead of your mouse.

Using keyboard shortcuts can increase your efficiency because you don’t need to
take your hands of the keyboard to perform an action.

You will probably already know and use some of these shortcuts. If you don't,
even if you do, there could be one here that makes your life a whole lot easier so
give them a go!

oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo

Keyboard shortcuts can generally be found by searching the Help index of the
program you are using.

oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo

Shortcuts for MS Word

I want to... Press
Select everything in the current document CTRL+A
Bold the text CTRL+B
Copy the selected item CTRL+C
Format text CTRL+ D
Center text CTRL+E
Search the current document CTRL+F
Go to a specific location in the current document CTRL+G
Replace text in the current document CTRL+H
Italicise Text CTRL + 1
Justify Text CTRL+J
Create a Hyperlink CTRL+K
Left Align CTRL+L
Create a new document CTRL+ N
Open a file CTRL+O
Print CTRL+P
Right Align CTRL+R
Save CTRL+S
Underline Text CTRL+U
Paste CTRL +V
Cut CTRL + X
Redo CTRL+Y
Undo CTRL+Z
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Keyboard Shortcuts (cont)

The Windows Logo Key

f‘ ] Have you ever wondered what that key with the windows logo on it does?
~ Never been game to press it? Well it performs a couple of neat little tricks

too.
| want to... Press
Go to the Start menu Windows
Go to the desktop Windows + D
Open My Computer Windows + E
Minimise all of the windows Windows + M
Restore the minimised windows Windows + Shift + M
Search for afile Windows + F
Open Windows Help Windows + F1
The Tab Key

And let’s not forget about the TAB key. The TAB key has a few more tricks up its
sleeve than creating an indent for a paragraph! It's a handy little gadget that lets
you navigate around windows without having to take your hands off the keyboard
and click yourself silly. (It will be your best friend if your mouse packs itin...)

| want to... Press

Go to the next option in a dialogue Tab

box

Go back to the previous option in a Shift + Tab
dialogue box

Move forward through tabs CTRL + Tab

Move backwards through tabs CTRL + Shift + Tab
Switch between my open windows ALT + Tab

And one last one to change the size of your font when you’re not quite sure what
you want to change it to! It’s easier than clicking and looking, then clicking and
looking, then clicking and looking again...

| want to Press
Make my text smaller Select text then CTRL + Shift + <
Make my text bigger Select text then CTRL + Shift + >
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Working with Text

Selecting Tex

Frequently in Word you are required to select or highlight text before you can
make your changes. The most common way to select text is to click and drag, but
sometimes (and it's usually when you're in a hurry) it can be a bit painful to
precisely highlight the text you want. Take heart, it’'s happened to everyone at

some stage!

Here are some quick and easy methods to select the text you need.

® To select one word:

® To select an entire sentence:

® To select an entire line of text:

® To select an entire paragraph:

® To select multiple paragraphs:

® To select any amount of text:

® To select everything:

® To make a vertical selection:

® To select items that aren’t
next to each other:

Double-click on the word.

Hold down the control (Ctrl) key and click
anywhere in the sentence.

Move your cursor into the left margin,
left click when the cursor turns into an
arrow head.

Move your cursor into the left margin,
double click when the cursor turns into
an arrow head. OR Triple-click anywhere
in the paragraph.

Move your cursor into the left margin,
click when the cursor turns into an
arrowhead then drag up or down.

Click at the beginning of the text you want
to highlight, scroll to the end of the text,
then hold down the shift key and click at
the end of the text.

Hold down the Control (Ctrl) key and
press A. OR move your curser into to the
left margin and triple click when the
cursor turns into the arrow head.

You can select text vertically ( maybe you
need to bold the first few words of every
line in a list.) Hold down the Alt key, click
and drag up, down or across to select.

Select the first item, hold down the
control (Ctrl) key then continue selecting
the items you want.
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Working with Text

S lple =X (cont)

® To deselect your selection: Click anywhere on your page.

............................................................................................................................
.

Hmmm, selected too much or too little? You don’t have to go through the whole
process again! While your text is still highlighted, hold down the shift key and use
the directional arrows on your keyboard to extend or reduce your selection. The left
and right arrows will select/deselect one letter at a time. The up and down arrows
select/deselect the entire line above or below.

............................................................................................................................

Deleting Text

® To delete one character to the right: Press the Delete key.

® To delete one character to the left:  Press the Backspace key.

® To delete the word to the right: Press Control (Ctrl) and Delete
® To delete the word to the left: Press Control (Ctrl) and Backspace.
® To delete several words at once: Hold down the Control (Ctrl) key and

press Backspace Or Delete repeatedly.

Drag to Move Text

When you need to move or copy text in a Word document there is an easier, more
efficient method than the old cut and paste. Once you have mastered it, you’ll
wonder how you lived without it!

Move Text

Highlight the text you want to move. Let go of the left mouse button, then click on
your selection again, this time keeping the left mouse button pressed down and
drag your selection to its new home. Let go of the left mouse button and your text
will appear.

Copy Text

Follow the steps above, this time holding down the Ctrl key as you drag, let go of
the left mouse button and your copied text will appear.

...............................................................................................................

...............................................................................................................



Smart & Sassy

Fix the Things That Drive You Nuts.

Overtype Mode

Why is the text disappearing as | type?

EAERRCEL = T s R AR T |

This is because Word is in Overtype Mode and SRR T B

Overtype Mode does exactly as its name suggests, o

types over the top of your existing text. The Insert ARSI S ol e S(ela g

key i d to turn Overtype mode on or off, and it | status bar if you are in
ey Is use_ . yp h ' : Overtype Mode

can be mistakenly activated because it rests just

above the delete key.

To stop overtype mode, and return from the brink

of insanity, press the Insert key OR double click e s 0340 0 s msga i)
OVR on the status bar, OR go to Tools> Options-> /

Edit and uncheck the box next to Overtype mode.

.............................................................................................................................

If you really really dislike Overtype mode, you can permanently remove its

H#%6& association with the insert key by going to: Tools-Customize-Options-Keyboard
Categories-All Commands-Commands-Overtype-Current keys, click on Insert,
then click Remove, then close your dialogue boxes.

.
.............................................................................................................................

Grammar Checker

If you can’t stand that wriggly green line that supposedly points out grammatical
errors in your document, (which by the way are mostly insane) you can turn the
grammar check option off.

Go to Tools = Options, click on the Spelling and Grammar tab then clear the
checkbox next to Check grammar as you type. The wriggly green lines will
disappear.

Entire Word Selection

When you are trying to select or highlight a couple of letters in a word, it can be a
bit painful when Word automatically selects the entire word every time. This
‘feature’ can also be turned off.

Go to Tools-> Options, click on the Edit tab then clear the checkbox next to
When selecting, automatically select entire word.

.............................................................................................................................

If you really need to, you can turn these options back on by following the steps and
marking the checkbox.

..............................................................................................................................
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Fix the Things That Drive You Nuts.

Automatic Numbered Lists

When you put a number in front of a new line, Word will automatically create a
numbered list whether you want it to or not.

To turn it off go to Tools> AutoCorrect Options click on the AutoFormat As
You Type tab and clear the checkbox for Automatic numbered lists.

You can still create numbered lists by clicking on the numbering icon on the
formatting toolbar.

Break a List

Sometimes you need to add a comment, explanation or just a blank line to a list
but when you press enter the bullets just keep on keeping on.

What to do? Hold down the Shift key when you press Enter and you'll never have
to worry about it again.

Show/Don’t Show Toolbars
You can have any toolbars you like showing in Word, there are 19 to choose from!

You do this by going to the View menu, clicking on Toolbars and then selecting
the ones you'd like to be displayed, or clear the ones you don’t use all the time. OR
you can simply right click anywhere on any toolbar to do the same thing.

Remember, the more toolbars you've got stacked up in Word, the less space you
have for viewing your document. So only display the ones you are using.

Simplify the Toolbars You Keep

There are buttons on your toolbars you never use and probably never will. For
example, | never use cut, copy or paste from the toolbar because | use keyboard
shortcuts or the context menu that appears when I right click on my selection.

You can customise your toolbars by banishing the buttons you never use and
adding the ones you want if they’re not there already.

Click on the little arrow at the end of the toolbar, click Add or Remove Buttons
click on the name of your toolbar (standard, formatting etc) then check or clear
the options as you’d like them to be displayed.

Remember streamlining your toolbar does not mean you loose the function of the
buttons you remove, it just makes your workspace more efficient.
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Customise Your Toolbars for You.

All those buttons available for the toolbars, but there’s not the one you want?

You can easily add a button to your toolbar for any command you constantly
access from the menu bar, for example, Word Count, Envelopes and Labels,

Letter Wizard etc.

Click on the little arrow on the end of your toolbar, click on Add or Remove
Buttons—> Customise»> Commands, choose the category your command comes
from (where you go on the menu bar to access it) scroll through the commands,

click on the one you want and drag it up onto your toolbar.

To remove it follow the same steps and this time drag it off the toolbar.

Context Menus

The quickest and easiest way to access menu commands is to right click on the
item you are working on, be it a picture, text, table, WordArt etc. This will display
a context menu specifically for the item you have selected, and you can choose

most of your commands from there.

For example:
I want to find another word to use instead of ‘choose’.

ch}

A Fet.,

I right click on the word ‘choose’, the text context menu NUNE -

opens.

froat
te ho| % topednk...

13 LockUp..,

i=| Bullets and flumbering...

VordArt etc. This will display

synonyins

§ Translate

I go to Synonyms and | am presented with a list of
alternative words I can use.

If you have never been a right clicker, you'll appreciate how | |

Behindtest In Front of text

efficient it is.

Always Show Full Menus

When you click on one of the menus on the menu
bar, it will show you the list of commands
abbreviated to those used most recently. You can
access the rest of the commands by either waiting for
about six seconds for them to appear or clicking on
the down pointing double arrows at the end of the
list.

If you always want the full menu list to appear, and
lets face it, who's got six seconds to waste, go to

Selext Texet with Simiar Formatting

deride

Customize

Toolbars | Commands | Options

Personalized Menus and Toolbars

Show Standard and Formatting koolbars on bwo rows

‘? Always show Full mepus

Reset menu and toalbar usage data

Olfper

] Large icans

] List Fant names in their Fant
¥ Show ScreenTips on toolbars

Tools-> Customise—> Options and check the box
next to Always show full menus.

Shaw shortcut keys in ScreenTips

lenu animations: | (System default)

L Eevboard,

PIX)

Close

You can also choose to display large icons, list font names in their font, show
screen tips on toolbars, show shortcut keys in screen tips and change the menu
animations to further customize Word to work the way that suits you best.
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Avoid shift for capitalisation

Depending on the kind of text you type, you can avoid having to press Shift when
you capitalise the first letter of a sentence. This can improve your efficiency if you
do a lot of typing. When you type in the punctuation to finish a sentence, or you
type in the name of a day, Word will

. . . AutoC : English (LS. '

automat|cal|y put the Cap|ta|s in for you.
AutoText AutoFormat Smart Tags
i . AutoCorrect AutoFormat As You Type

Go to Tools> AutoCorrect Options and click S G R
the AutoCorrect tab. Check the boxes next to R,
Capitalise first letter of sentences and P —
Capital ise names Of dayS_ < [¥] Capitalize First letter of table cells [ correct keyvboard setting

‘ Capitalize names of days
Correct accidental usage of cAPS LOCK key

While you have the AutoCorrect dialogue DOX =5 epiace tet 26 you type

open, make sure the Replace text as you type Replace: with: @ Flaintext O Formatted text

box is checked and you will be able to add your L. depending on the kind of text you type

own AutoCorrect entries to save yourself time. -
o sccomois

For example, if you would like to type the name seeponate ercordfato Y

of your school without having to press shift all
the time to capitalise it, type the name of your
school (without capitals) in the Replace box then ok ][ cance
type the name of your school with capitals in the
With box and click OK.

Abtomatically use suglestions from the spelling checker

Quick & Easy Horizontal Lines

When Replace text as you type has been activated, you can quickly add
horizontal lines to your document by typing three characters and then hitting
enter.

Three Hyphens (-) then Enter

Three Underscores (_) then Enter

Three Tildes (~) then Enter

Three Hashes (#) then Enter

Three Asterisks (*) then Enter

Three Equal Signs (=) then Enter



Smart & Sassy

Quick and Easy Arrows and Symbols

Have you ever needed a copyright symbol, arrow or even a smiley face? With the
Replace text as you type activation, type these characters and word will correct

them appropriately.

(c)=© nNn=® (tm)=™
<== = <=>=® =—=> =
(=0 ) =0© 1 =0

Why Can’t | Move My Picture?

&

Unless you change it, when you insert a picture, Word uses the in line with text

wrapping style by default.

This means your picture is sitting in the same

line as your text and can not be moved

Wrapping style

~

In line with text

ot

Sguare

laf

Tight Behind text  In front of text

== =

around as freely as it would if it were in front
of the text for example.

You can change the text wrapping style by clicking on your picture and going to
Format-> Picture-> Layout and selecting the style you want, OR right click on
your picture, go to Format picture-> Layout, OR click on your picture and click
the dog box on the picture toolbar, which appears whenever you select a picture,
then select the style you want. The dog box will give you a preview of how the text

will wrap around your picture.

Set Your Insert Picture Option

You can change the way Word inserts your pictures to

the wrapping style you use most often.

Go to Tools=> Options to open the Options dialogue
box. Go to the Insert/Paste pictures as drop down

box and select the wrapping style you use the most. __,

Click OK and you will not have to waste time fiddling
with the way your pictures are inserted again, unless

you want to.

10

Options

Security

Lser

View

Information

General

Editing options

X

Speling & Grammar Track Changes
Compatibility File Locations
Edit Print Save

Typing replaces selection Use smart paragraph selection
Drag-and-drop text editing Use CTRL + Click ko Fallow hyperlink,
[[] Use the INS key For paste [[] when selecting, automatically select
[ overtype mode
Lse smart cursoring
Picture editar:

Ft Office Word

Insert/paste pictures as;
Sguare

o

e d

Tight

Biehind text

In front of text

entire word
] Prompt to update style
Keep track of Formatting
" [] Mark Formatting inconsistendies

Smart cut and paste Settings...

Hormal -
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Compress Your Pictures

Picture files are generally quite large. When you insert
pictures into a document it increases the size of the
document accordingly. To save space on your hard
drive or email your document you will have to reduce
the file size by compressing your pictures.

To reduce the size of your picture, open your
document, right click on one of your pictures, click on
Format Picture-> Picture and click Compress

\ 4

This will open the Compress Pictures dialogue box
where you can change the resolution of one or all of
your pictures to drastically reduce the file size.

Checking the Change resolution for Print radio

Format Picture E‘
Colors and lines | Size | Layout || Web
Crop from
Left: Oem E Top: Ocm =
Right: Ocm B Bottam: 0cm E
Image control
Colar: Automatic A4
Brightness: € > 50% E
Contrast: < > 50 % S
Compress Pictures g \

Apply to

O all pictures in document
Change resolution
() WehjScreen

Res
> () Prink

button will ensure your pictures will still look good
when they are printed.

Also check the Delete cropped areas of pictures boX |

to further reduce file size, because even though you
can't see the deleted areas, Word still retains the
information pertaining to them.

Notes:

11

() Mo Change
Opkions
Compress pictures
—> Delete cropped areas of pi

alution: 200 dpi

ctures
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Columns and Breaks

Inserting Columns

Columns are easy to create by going to » 7|x
Format=> Columns OR clicking on the &umns )
columns icon on the standard toolbar. Fressts
. . . one Two  Three  Left Right
This will open the Columns dialogue box
where you can choose how many columns | tumber of columns: ! v
you would like, their width, whether to Width and spacing Preview
apply them to the whole document or just col #: width: Spacing:

this point forward, you can place a line L | [15.33em 3
between them etc.

Easy, right? Yes, but how do you stop the
column formatting when you only want

columns in part of your document? apply to: | TEREREN: v
Breaks
This leads us to Breaks, the paracetamol for @RT'
changing layouts and formatting within one Break J_J
document. el s
() Page break

You can use Breaks to vary the layout and change O Column break
the formatting of different sections within a page ) Text wrapping break
or between different pages of your document. St el B

. ) Mext page
Go to Insert> Break and the Break dialogue box @ Corfimimue]
will appear listing the different types of breaks you {}E;;;"H%;
can apply. ) odd page
There are seven different Breaks to choose from so Lok [ cancel

let’s have a look at what they all do.
Break Types

Page break: Forces everything after the break onto a new page.
Column break: Forces everything after the break into a new column.

Text Wrapping break: Used to separate text around objects like pictures, mostly
on web pages.

Section Break Types

Next Page: Starts a new section on the next page.

12
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Columns and Breaks (cont)
Continuous: Starts a new section on the same page.

Even page: Starts a new section on the next even numbered page.

Odd page: Starts a new section on the next odd numbered page.

Removing Breaks

Most of us work in the print view which shows our document as it will be printed
so you can’t see a mark where you've inserted a break. If you switch to Normal
view on the menu bar you will be able to see your breaks as dotted lines that run
across your page.

Go to View-> Normal, click on the break you wish to remove (it will be named)
and press delete.

Notes:

13
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Tables

There are several ways you can create a table in your document.

® You can go to Table—> Insert table. Weerigiabe X

Table size

Specify the number of columns and rows p|  umber of columns: E

Mumber of rows: 2

Ak |4

The AutoFit behaviour

AutoFit behavior
(%) Fixed column width: Auta
O AukoFit ko contents
() AutoFit to window

able style: Table orid » |AutoFormat...
>

v

4%

You can also choose one of the many different table styles
available when you click on the AutoFormat button.

If you use the same type of table a lot you can set Word to
remember it by checking the box next to Remember
dimensions for new tables.

[ remermber dimensions For new tables

v

OF, ] [ Cancel

Click OK and there is your table ready to be filled.

#® OR you can click on the Insert Table button on the
standard toolbar.

i T
Wl fge

Simply drag across the grid to select the size of the table =]
you want. When you let go of the left mouse button, your |
table appears on your page. 30140

Convert Text to Table

You can also convert your text into a table which is great if you already know what
the table will contain. However, when you convert text to a table, a delimiter such
as a comma, paragraph marker, or tab must separate columns of text for it to
work.

It sounds more complicated than it really is and you’ll probably use it a lot once
you get the hang of it.

Example:

Type in your information, separating columns with a comma. You do not place a
comma (delimiter) at the end of the last column, when you want to start a new
row just press enter. You should have something that looks like this.

Name, Age, Lane, Time, Place
Ron Weasley, 17, 1

Harry Potter, 16, 2

Hermione Granger, 16, 3
Albus Dumbledore, 1156, 4

14
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Tables (cont)

Now we’ll make it look like this.

Name Age | Lane | Time | Place
Ron Weasley 17 1
Harry Potter 16 2
Hermione Granger | 16 3
Albus Dumbledore | 1156 | 4

Highlight your text and go to Table->Convert>

Text to Table this will open the Convert Text to
Table dialogue box where you can specify column
width, (AutoFit to contents makes it nice and even)

and AutoFormat options.

The table size will already be selected based on
where you have placed your commas (delimiters).

Don’t forget to make sure Commas is checked

under Separate text at.

Click OK and Voila!

Moving around a Table

v

Convert Text to Table

Table size

Mumber of columns:
Mumber of rows:

AukoFit bebavior

() Fixed column veidt

() AutoFit to
Tahle style: {none)

Separake text at

(") Paragraphs
() Tabs

h:

windon

@ Zammas
) Other:

AutoFarmat. ..

oKk |

[ Cancel

Each little rectangle in a table is called a cell. To move from cell to cell you don’t
have to click in every cell, use the Tab key to move left to right and Shift-Tab to

move from right to left. You can also use the directional arrows on your
keyboard to move left, right, up or down.

To enter text into a table, simply type as you normally would. Press Tab to move

to the next cell.

Header Row: The first row =—>
in the table.

Row: Runs horizontally. —

Name Age | Lane | Time | Place
Ron Weasley 17 1
Harry Potter 16 2
Hermione Granger | 16 3
Albus Dumbledore | 1156 | 4

4

Column: Runs vertically.

15
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Tables (cont)

Insert a Row at the Bottom of a Table

To insert more rows at the Name Age | Lane | Time | Place
bottom of your table, click in Ron Weasley 17 1
the very last cell and press the ——zrry-Potter 62
Tab key. Hermione Granger | 16 | 3
Albus Dumbledore | 1156 | 4
A 4

Inserting Extra Rows and Columns Within the Table

Youcanadd anewrowor column

anywhere in a table. Took [ Table | Window Help
. || orawTable HE B =03 1 100%
Click in the row or column where you wish =1 :: - f‘ i IE
S L | Columns to the Left .
to add a row above or below or a column B oo o > PO
to the right or left. S - T i3
) f AukoFik » _?f Rows Below |
Go to Table=> Insert=> and click on the 1] i g .S le
. 21 sort...
option you need, Rows above or rows @ i he Tare
below, columns to the left or columns to Tt Poprtes.. St | Ron Weasley
t Praper ssthe
- Harry Potter
the rlght. ¥ Hermione Gran|
Alhae Thimbled

Inserting an Extra Cell

Have you entered something wrong into a cell or skipped a number or made a
mistake and it...

‘just has to be in the middle somewhere and now I have to move all the other data
in that column down in this huge table because simply adding a row won't fix it
and now | have to cut and paste or undo everything and start again and there’s a
deadline my boss is breathing down my neck and now I’'m not going to make it
and and | just HATE TABLES and why can’t | just ADD AN EXTRA CELL...!?’
(Transcript from a real telephone call from a very :
stressed friend of mine.) Insert Cells g|
Thankfully you can Insert Cells. Click in the cell that’s gg:::zz::z;g:tn

the cause of your mlsery_then go to Tables—> Insert> ) Tneert entire mﬁ

Cells, and check the option that saves your sanity.

O Insert entire column

[ (4 ] [ Cancel

16
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Tables (Cont)

Select a Cell

To select a cell, move your curser to the bottom left hand corner of the cell. When
it changes to a black arrow, click once OR click in the cell and go to Table>

Select—> Cell

Select a Row

To select an entire row, move the curser to the left hand side of the row, when it
turns into a white arrow click once, OR click anywhere in the row and go to

Table-> Select> Row.

Select a Column

To select an entire column, move the curser to the top of the column, when it
changes to a black down arrow, click once, OR go to Table-> Select-> Column.

Select a Table

To select the entire table, move the cursor to the top left hand corner of the table

and click on the four headed arrow, OR go to Table-> Select-> Table

Heading Rows

If you are working on a large table that continues onto the next page, your table
heading will only appear on the first page unless you specify that you want your

headings to repeat at the top of your table on a new page.

Click on your heading row and go to Table> Heading Rows Repeat

Formatting Tables

There are all sorts of ways to format your table, the easiest way to
access most of these options is to right click on your table to open
the context menu.

From here you can change the width of columns and rows, change
the colour and weight of the borders and lines, add shading and
patterns, change the text direction, change cell alignment etc.

You can also go to the Table Properties dialogue box and determine
your table’s position relative to the page, margin or column.

Right click on your table, go to Table Properties> Table>
Positioning and specify the horizontal and vertical alignment you
want.

Paste

Em‘t Table...

Delete Rows

Spitt Cells...

Borders and Shading...
Text Dwrection...

Cell Alignment

AutoFit

Table Properties...

Now you can make that #%&! table sit dead center if you want to!

17
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Tables (cont)

Go ahead and make your table as eye catching or businesslike as you desire.

Neme Lge | Lane | Time Dace
PRon W /7 L5698 h

Hogwarts Open Broomstick Stakes 2008

Name Age Lane | Time | Place
Ron Weasley 17 1
Harry Potter 16 2
Hermione Granger 16 3
Albus Dumbledore 1156 |4

Sorting your Table

The results are in and it’s your job to make a new table sorted by first place to last
place. Don’t groan, you don’t have to start all over again. Enter the new
information into your table and get Word to do the rest for you.

Click on your table, go to Table-> Sort, this will open the Sort dialogue box.

Select the column name or number you
want to sort in the Sort by field.

—

Sort

Ascending
Type: W @ =
> =+ Humber (") Descending

Next, select Number in the Type field.
(you can choose from Number, Text or
Date)

Click the button to specify ascending or
descending numbers.

V| A

% ascending
e = ('} Descending

If your column names are not showing in
the Sort by field, make sure you have

selected Header Row under My list has. _|

Click OK and it’s all sunshine and
cartwheels.

18

X

sing: |Paragraphs hd |
Then by
My lisk has
(%) Header row () Mo header row
Opkions. .. [ o] ] [ Cancel
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Tables (cont)

Now your table is sorted from first to last place with a couple of clicks!

Neme % Sane | Time Dhace

Ren Weastey /7 / 450,95 |

Add a Title (Merge Cells)

To add a title to your table insert a row above the header row on your table.

Title Row > .
Header Row , | Name Age | Lane | Time | Place
Ron Weasley 17 1
Harry Potter 16 2
Hermione Granger | 16 3
Albus Dumbledore | 1156 | 4

Select the new row, right click on the selected row and click Merge cells from the
context menu, OR go to Table-> Merge cells. Now you can type in your heading
and format it to your liking.

Hogwarts Open Broomstick
Stakes 2008

Word will only recognise the first row in a table as a header row. If you want to
sort a table which also has a title row, you can highlight the column you want to sort
by dragging down it, and follow the same steps. It's probably best to leave adding a
title row until you've finished your table.

ooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo



Smart & Sassy

The Drawing Toolbar

Draw~ g |Autoshapest \ N JO A J 22 8] [ d-Z-A-S=5 d Ij!

The drawing toolbar makes MS Word more than just a word processing application and
moves it into the realm of desktop publishing. You can display your Drawing toolbar
permanently by clicking View-> Toolbars-> Drawing.

So what do all the little buttons do?

2P = s | Click this button to find a pull down menu with easy access to the sanity
o savers like rotate, nudge, align, and the grid.

This is where you find all those cool shapes like stars, block
| AutoShapes - -II arrows, banners, flow charts, connecters and speech bubbles.

Allows you to click and drag to draw a line.
“‘\M o000 000O0 (Hold down the shift key to keep your line straight.)

“w, »  Inserts an arrow when you click and drag.

Click and drag to form a rectangle.

I:l _ (Hold down the shift key for a square.)

':::' - You guessed it, click and drag to form an oval.
(Hold down the shift key for a circle.)

1
) & | SMART | Draws a text box when you click and drag.

:::::::::::::

d S a S S y Create cool text effects with WordArt
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The Drawing Toolbar

|-

2 2 2 2 2 2 2 2 2 2 2 J

Parpple

This button inserts diagrams or organisation charts
which you can then customise.

You can insert clipart with the Clipart button

(Faster than clicking insert = picture = clipart on the menu

bar)

Insert your photos and pictures by clicking on the
insert picture button.

(Faster than clicking insert = picture = from file on
the menu bar)

The Fill bucket lets you change the colour or fill effect
of a selected object.

You can use the Line Colour button to change the
colour and/or pattern of your line.

Just like the one on the format bar, the Font Colour
button changes the colour of your text.

Line Style changes the thickness of your line.

Dash Style lets you select a dashed style for your line.

21
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The Drawing Toolbar

!

Notes:

¢ You can change the appearance of your arrow heads

with the Arrow Style button.

The Shadow Style button lets you choose a shadow for
your AutoShape.

If you click on Shadow Settings at the bottom of the
drop down menu you will find further options to
nudge your shadow around and change the colour of
it.

You can add 3-D Style effects to your AutoShapes with
the 3-D button.

If you click on 3-D settings at the bottom of the

3-D drop down menu, you can customise the tilt,
depth, direction, lighting, surface texture and colour.

22
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Creating Impact with Text

There are many different ways to improve your documents by formatting the font

you choose and adding text effects.

You are probably familiar with changing the size and colour of your text by using
the standard toolbar, or using bold and italic for emphasis, but there are a lot
more options available in MS Word which, when used sparingly, add visual

impact and a bit of pizzazz to your documents.

Formatting Fonts

Start by highlighting some text then clicking Format—> Font on the menu bar.

This will open the Font dialogue box.

Font Tab
Not only can you specify the font style and size from

here, but you can also add text effects to enhance your

document. For Example:

Subscript
Oufline

Shadow

Superscript

SMALL CAPS

colour.

Character Spacing Tab

You can expand or condense your text as well as
raise and lower it without increasing the font size.
These options are very handy when you are creating
documents such as certificates and letterheads and
you need a precise fit. For Example:

Normal Spacing
BURCHER PUBLIC SCHOOL

Expanded by 5 pt
BURCHER PUBLIC SCHOOL

Condensed by 1 pt
BURCHER PUBLIC SCHOOL

23

Font 2
Fonk Character Spacing | Text Effects
Font style: Size:
Regular 12
Georgia ~ 3 ~
Giddyup Std Ttalic 9
Gigi Bold 10
Gill Sans MT Bold Italic 11
Gill 5ans MT Condensed b =
Font calar: Underling style:
Automatic | [tnone) -
Effects
[ strikethrough [ shadow [ Small caps
[ pauble strikethrough [ cutline [ all caps
[ suerscript [[] Emboss [] Hidden
[ subscript [JEngrave
Previgv
Georgia |
This is & TruaType fFont, This Fant will be used on both printer and screen,
Dot
Font Egl

Font Characker Spacing | Text Effects

Scale: 100% ~

Spacing: | Expanded w| By SRt E

Position: By: |Spt £

[ kerning For fanks: % | Paints and above

Preview

Georgia

This 15 a TraeType fone. This font will be used on both printer and screen.
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Text Effects Tab = X
Font Chatacter Spacing | Text Effects

If you are creating a document that will be viewed s

online, you are in the right place to add cool text Birking ckyaund

animation like a blinking background, sparkles and g R e

Shimmer

shimmers. Remember, text animations do not print
and can only be viewed on a computer. (Maybe you
could jazz up some email attachments.)

Preview

Genrgla

Drop Caps

e see Drop caps used all the time in magazines, —-—
story books, manuscripts etc. Drop caps

emphasize the first letter on the page and can : wol |w
add a touch of style to your documents. Drop — | =

caps are easy to create by going to the menu bar |

Fonk:

and clicking Format - Drop cap. —

You can then select the position you would like your Drop cap e from 2t
to sit, the distance it will be from the text and the font you
would like to use.

4 (<x | £

0.4 cm

Drop caps can be edited and formatted just like normal text.

If you need to further adjust the way the text wraps around the Drop cap or the
distance from text and position, double click on the Drop cap frame for more
options.

WordArt

WordArt allows you to easily produce high impact text.
You can add WordArt by going to the menu bar and clicking Insert = Picture >
WordArt, OR by clicking the WordArt button on the drawing toolbar.

This will open the WordArt gallery where you can then select the style you would
like to use. Type in your text, you can also change the font style and size at this
stage if you want to, click OK and position your creation.

There are preset designs to use like the samples below, but the possibilities to
create something unique are endless, which we will explore.
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WordArt

WordA

Once you have inserted your WordArt, the WordArt toolbar will appear.
Al | EdtText... | S P A B | & p
WordArt Toolbar

=
Abh = AV
4 = s
The toolbar lets you change things like the colour, shape, text, spacing etc, and
create something really distinctive. Let’s have a look at what we can do with it.
-Giiﬂ_ Insert WordArt.
| Edit Text... Change your text, font, size, bold and italic.
% Access the WordArt gallery.
{%( position etc.
N

Format WordArt- change the colour, fill effects, patterns, layout,
Change the shape.

}E Text Wrapping options (in front, square, tight etc.)
.E.-H. Same letter height.
ég Vertical text.
= Alignment.
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AV Letter Spacing.
LE Atting WordArt

You are probably familiar with changing the fill colour of your WordArt by
selecting a colour from the drop down box, but the options don’t end there.

In the colours and lines tab you can choose Format WordArt X
even more colours than those listed by going t0 || cuoeandines | sz | Layout —
more colours, you can fiddle with the Fil
transparency, select a different line style etc. Colors | e—

Transparency: Mo Fil 0% £

ine EEEEENEER
You can create all sorts of cool effects yourself I s
by clicking on the fill effects button. Celor: EEEEEEE

| |

Dashed:

Arraws

Begin style:
More Colors, ..

EERn el Fill EFfects. ..

~S—————

Fill Effects
|
Use the Gradient tab to create your own colour
blends or choose one of the 24 presets to get this
effect.
Use the Texture tab to add different surface % a T @E
effects to your text.
The Pattern tab has 48 different patterns to use, D
and you can mix two colours of your own choosing. D

The Picture tab allows you to fill your text with a
photograph or picture creating some awesome text
effects.
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It always helps to have cool fonts and you can download themed fonts for free at
www.simplythebest.net/fonts/movie_fonts.html

Shadows and 3D

But wait there’s more! You can add a shadow or a 3D effect, throw in some
AutoShapes from the drawing toolbar or some clipart to really catch the eye.

rali

i

—
Y 4
Y

Xl
I

g
i

Remember, your aim is to produce an effective piece of communication.
Always check your spelling, especially if your computer defaults to US English.

Too many fabulous creations on one page will create visual confusion and look
unprofessional.

To create maximum impact, less is more.

Just because you can, doesn’t always mean you should... Have fun!
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Notes:
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